Need some help?

There is no articles related to this label

Is my smartphone compatible with Vodafone Wallet?

Vodafone Wallet is compatible with smartphones running Android 4.0.3 and later. You can find a list of compatible devices in the ‘eligible devices’ tab at the bottom of the page.

These devices allow you to make secure contactless payments as they have Near Field Communication (NFC) functionality. You will also need an NFC / contactless SIM which, you can order here, or pop into store to pick one up.  

Before installing Vodafone Wallet, make sure that you have the latest software your phone. You can check this in the ‘About’ section of your phone’s settings.

.
.
.
.
.